The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

Adobe reader

Saltar a: navegación, buscar
Adobe Reader
Adobe Reader.jpg
Logo de Adobe Reader

Desarrollador: Adobe Systems Inc.
Licencia: Propietaria
Web: Adobe.com

Acerca de

Adobe Reader es un programa para visualizar, imprimir y anotar en documentos en formato PDF. Puede abrir y manejar todo tipo de contenido en PDF, incluyendo formularios y contenido multimedia.

Características

Visita la página oficial del producto para consultar las características de Adobe Reader

PDF

El formato de documentos en PDF corresponde a un est√°ndar. Echa un vistazo al art√≠culo en la Wikipedia sobre este tema. Hay muchas aplicaciones para ver, editar o crear archivos en PDF, pero no todas soportan las caracter√≠sticas al completo. Adobe crea nuevas caracter√≠sticas que tardan alg√ļn tiempo en incorporarse en los est√°ndares. S√≥lo la √ļltima versi√≥n de Adobe Reader soporta todas esas nuevas caracter√≠sticas creadas por Adobe.

Adobe Reader no ser√° distribuido m√°s en openSUSE

Adobe no facilitar√° m√°s actualizaciones de seguridad para Adobe Reader bajo Linux.

Además el paquete de software RPM "acroread" se va a eliminar de la distribución a partir de openSUSE 13.1, para proteger así a los usuarios de openSUSE. Para más detalles puedes visitar este enlace (en inglés) openSUSE Bug 843835 - VUL-0: acroread: Linux support is discontinued o este otro openSUSE Bug 849112 - acroread no longer included.

En este enlace (en inglés) puedes ver los ciclos de lanzamiento de los productos de Adobe Adobe products and Enterprise Technical Support periods covered under the new Lifecycle Policy en donde se listan los ciclos de lanzamiento para Adobe Reader y para otros productos. El soporte para la versión 9 de Adobe Reader se acabó en Julio de 2013. Las nuevas versiones 10 y 11 (Adobe Reader X y XI) ya no están disponibles para Linux.

Adobe Reader es simplemente el software binario no-libre de Adobe, así que no hay nada que openSUSE pueda hacer respecto a este tema.

openSUSE incluye varias herramientas para visionar archivos PDF, como Okular, Evince, MuPDF, poppler-tools y muchas otras. Hay herramientas activamente mantenidas y que corrigen los problemas de seguridad que surgen, bien sea por openSUSE o por sus desarrolladores principales.

Los usuarios de openSUSE que estén interesados en Adobe Reader deben ponerse en contacto directamente con Adobe, por ejemplo mediante este enlace: Adobe Reader.

En particular, para el Acuerdo de Distribución de Adobe Reader debes ponerte en contacto directamente con Adobe: Volume distribution.

Problemas y soluciones

En el momento de escribirse este documento (Noviembre de 2013) Adobe Reader es el √ļnico visor de PDF que soporta todas las caracter√≠sticas del est√°ndar. Por ejemplo, formularios XFA con JavaScript, firma de documentos y verificaci√≥n de la firma no est√°n soportadas por poppler tools lo que significa que tampoco lo est√°n en Okular o Evince. MuPDF parece que avanza en ese sentido, pero est√° sin acabar.

Formularios con JavaScript: Puedes observar que estos formularios no funcionan completamente cuando pulsas sobre los botones incluidos dentro del propio formulario y no ocurre nada. Esto puede que importe o puede que no. A menudo los formularios se muestran correctamente y pueden rellenarse utilizando Okular o Evince. Es mediante una cuidadosa comparación con el comportamiento de Adobe Reader cuando las diferencias se pueden evaluar y quizás puedan ser ignoradas.

Una muestra de un fichero PDF con un formulario puede obtenerse en esta dirección o quizás también aquí.

Hay otras soluciones alternativas: Adobe Reader X bajo Wine, Adobe Reader XI en una m√°quina virtual con Android, Foxit Reader bajo Wine...

Adobe Reader 9 bajo Linux

Adobe Reader puede seguir consigui√©ndose desde Adobe, pero para Linux s√≥lo ofrecen la versi√≥n 9, que no tiene actualizaciones. Quiz√°s es razonablemente seguro usar Adobe Reader 9 pero inhabilitando JavaScript, impidiendo que tenga acceso a Internet, y protegi√©ndose mediante AppArmor. Realizar esto corresponde al Administrador del sistema, pero desde luego nada se puede reclamar a openSUSE si ocurre alg√ļn incidente no deseado.

Adobe Reader X y XI bajo Wine

Los √ļnicos Adobe Reader que se conoce que trabajan bien bajo Wine son las versiones 8 o 9. De todas formas estas no recibir√°n m√°s actualizaciones por parte de Adobe, as√≠ que usarlas puede ser tan perjudicial como usar las versiones nativas para Linux. Las versiones X y XI no son actualmente instalables bajo Wine, pero esto puede que cambie pronto, de acuerdo a lo expuesto en este art√≠culo (en ingl√©s) Wine 1.5.25 Fixes Adobe Reader XI Installation.

Adobe Reader X y XI en una m√°quina virtual Android

Esto funciona sin problemas, pero la interfaz del usuario es incómoda: simula una tablet, pero no es una verdadera tablet, así que no puedes teclear en la pantalla. El soporte al teclado es limitado, y Re Pág/Av Pág no funcionan.

Este es un art√≠culo (en ingl√©s) sobre C√≥mo instalar Android en VirtualBox. Funciona igual en VMware (aseg√ļrate de elegir un disco duro virtual IDE, no funciona con los SCSI). Puedes conseguir Android para arquitecturas x86 (32 bits) desde aqu√≠ android-x86.

Necesitas una cuenta en Gmail para registrar Android, y necesitas ese registro para poder descargar ese software desde Google Play.

Adobe Reader X y XI En una m√°quina virtual con Windows

Funciona sin problemas, pero el inconveniente es que necesitas una licencia privativa de Windows.

Foxit Reader en Wine

Hay una versión de Foxit Reader para Linux, pero es antigua (2009) y tiene problemas de seguridad; así que debes usar una versión actual para Windows, y además instalarla en una máquina virtual o bajo Wine.

El lector Foxit Reader lo puedes conseguir de manera libre desde aquí: Foxit Reader download.

Wine puede instalarse desde el repositorio OSS, o una versión más moderna desde el repositorio "Emuladores:/Wine" (instala también wine-mono).

Foxit Reader puede instalarse sin problemas, para ello ejecuta "wine lo_que_sea_setup.exe". Se instalar√° un icono en tu escritorio. Algunos dicen que han asociado el lector Foxit Reader con archivos PDF.

La comprobación de firmas no funciona ya que Foxit Reader necesita usar Microsoft Windows provided "Signature-Store" que no está disponible en Wine.

Ver también

  • Evince: Un visor de documentos para m√ļltiples formatos de documentos, usado principalmente en GNOME.
  • Okular: Un visor universal de documentos usado en KDE.
  • MuPDF: Un visor de documentos PDF, ligero, realizado por los desarrolladores de Ghostscript.
  • Ghostscript: El int√©rprete para PostScript y PDF.
  • Poppler: El actual motor de renderizado usado por Evince y Okular.

Enlace externos